You need to log in to create posts and topics.

Permission denied when copying config to FTP

Hi Guys,

While trying to do some basic configuration with NetYce in GNS3 via a basic command job, I ran into the following issue. Do you have an idea why I am getting the Permission denied?

-- PreConfig - backup

[copy startup-config ftp://********:********@192.168.122.193previous/s5%5D => failed

[copy startup-config ftp://********:********@192.168.122.193previous/s5%5D

[Address or name of remote host [192.168.122.193previous]? ]

[Destination filename [s5]? ]

[Writing s5 ]

[%Error opening ftp://*****:*****@192.168.122.193previous/s5 (Permission denied)]

 

Gr, Jeroen

 

Hi Jeroen,

thank you for your message, I see there's a  / missing in the path: what kind of vendor is your GNS3 instance?

Thanks in advance.

Hi Jeroen,

 

Netyce is running in virtual box and it connects to some cisco switches (IOU) and routers (IOS) that are running in GNS3. On both switch and router it gives the same result.

 

switch version:

 

Cisco IOS Software, Linux Software (I86BI_LINUX_L2-UPK9-M), Experimental Version 15.0(20121031:162848) [dstivers-oct25-2012-golden_spike 103]

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Wed 31-Oct-12 09:42 by dstivers

 

router version:

 

Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9-M), Version 15.2(4)S4, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Sun 01-Sep-13 14:54 by prod_rel_team

 

GNS3 version: 2.1.11

 

virtualbox version: VirtualBox Graphical User Interface Version 5.2.18_Ubuntu r123745

 

Please let me know if you need more info.

Gr, Jeroen

Did you run net_setup.pl? I just tried reproducing the situation you described in this post and we both saw on the teamviewer session however I am only able to reproduce this situation by not running net_setup.pl.

Thanks in advance,

Jeroen

Hi Jeroen,

I did ran the net_setup.pl but with only one network adapter, i think that is wat caused the issue.

Gr, Jeroen

Hi Jeroen,

thank you for your reply, can you run yce_setup.pl and check if the filetransfer in command jobs works after that? Thanks in advance.

Hi Jeroen,

 

That works.  [copy startup-config ftp://********:********@192.168.122.193/public/previous/s1] => ok

Gr, Jeroen

Hi Jeroen,

Great to hear, I will mark this topic as solved and close it.

Kind regards,

Jeroen