You need to log in to create posts and topics.

Genesis password is not working

I have recently installed software on VM and earlier NetYCE01 password was working but all of sudden it stopped working.


Please guide how to retrieve it, is there any way through GUI ?

Hi Patil,

One reason I can imagine is the lack of time refresh.

If you don't have NTP running and you are running this on your laptop and it has been sleeping for a while, the timing could be off and therefore not allowing you access.

Several solutions to this:

  1. reboot your VM
  2. set the date manually using the `date` command.

If possible, you will want to set up NTP to overcome this issue. Depending on your setup you may need 2 interfaces (1x internal, 1x NAT).

Add another network card in your hypervisor and run This guide might help you along with the videos in course 1.

If this didn't help, please explain to me your setup. We could also set up a zoom call, so I can help you remotely.

Cheers, Bart

HI Bart,

Thanks for the swift reply, as suggested I rebooted VM a couple of times but it didn't work. Also, I am not able to set date or run as the password is not working.

Yes, we can setup zoom call, please confirm.

Hi, i now understand it is the CLI password you are referring to. These users and passwords are not changed automatically nor are they constraint by time.

(NOTE: the root user is disabled over SSH as a security measure)

There are 2 users, 'root' and 'yce'. Both have the password: "NetYCE01" by default. You may have changed them during the net_setup process as can be seen in video course 1. If you have changed the password if you have access to either of the users you are able to change the password of the other user, using the 'passwd' command. ('passwd yce' (if you are the root user) or 'sudo passwd' (if you are the yce user). If you don't have access at all you may download the VM again or you could use the single user boot process (single user mode).

Let me know if that is working for you.

PS. the GUI access is independent of CLI access. You may still access that using NetYCE/NetYCE01, unless you have changed these values. Normally no CLI access is required once the setup has been done.

Hi Bart,

It is not working still, I think I have to reinstall VM. Anyway no CLI access is required once the setup has been done as you said. Will let you know if there is any concern.

Hi Bart,

While accessing NetYCE through a browser, I am getting the following error:


Could not connect to backendPlease contact your administrator
Please note that I am able to ping to NetYCE VM from Machin and vice versa.
Kindly advice.

Hi Patil,

Based on the limited information on your setup, I'm assuming this instance is running on your laptop and it went to sleep and tried to come back... I'm assuming you've tried to reboot the device and the DB didn't come back online, even after a few minutes.

It must be an issue with the index of MariaDB. There is a script for this and you can read about it here:

This requires to have CLI (console/ssh) access to the netyce server. Log in as the yce user and run the script.

In case you haven't restored your CLI access I suggest to download a new image, which has been recently updated.

Let me know if there is anything else I can help you with.




Thanks a lot once again Bart for the immidiate reply.

Well, I had to reinstall to retrieve the password, you have correctly said that I might have changed it during net_setp and forgot it 🙁 , anyway it is working fine now. Will surely try the solution as suggested if not able to login to NetYCE again.